WetCanvas
Home Member Services Content Areas Tools Info Center WC Partners Shop Help
Channels:
Search for:
in:

Welcome to the WetCanvas forums. You are currently viewing our boards as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please visit our help center.

Go Back   WetCanvas > Explore Media > Acrylics > Partner: Chroma, Inc.
User Name
Password
Register Mark Forums Read

Salute to our Partners
WC! Sponsors

Our Sponsors
Reply  
 
Thread Tools Display Modes
  #1   Report Bad Post  
Old 12-20-2019, 08:41 AM
Achilleas's Avatar
Achilleas Achilleas is offline
New Member
Athens
 
Join Date: Jul 2011
Posts: 28
 
Hails from Greece
problem with Atelier Interactive colors

Hi!
In the past years I bought several Atelier Interactive 80ml tubes. Overall my experience was very positive and the quality/properties of the colors justified the higher price in comparison with other brands available in the local market.

BUT after a hiatus from painting I found out that some of the colors separated in the tubes or they were in a semi-rubbery consistency.

The most worriesome aspect is that these colors were unopened. I have over 25 tubes and these were either convinience colors that I never came to use or doubles of colors Im working with. Im noting that ALL the colors are properly closed and stored always, taking attention to wipe the threads of the tubes each time so that they wont leak or stuck closed.

I noticed that most of the offenders are transparent or semi transparent colours. Granted that the colors are about 4 years old but I have colors from Talens, W&N, Liquitex and Golden that are even older and in all those years only a titanium white tube from Daller Rowney that was actually bought as a discount went bad on me. Everything else is fine.
I tried to reconstitute them with afew drops of Aterier Interactive transparent medium. They seem to respond to a point but they are not the same buttery creamy paints atelier Interactive usually are. They are difficult to mix and they are streaky.
1) Is there something I can do to revive them?

2) Is it a bad batch? Or they are all prone to drying inside the tube?
3) Could it be a bad packaging design?



Im not intending to bash Chroma company, I do very much like the colours (when the work as intended), but they are also expensive and I dont know if I should invest more money if there are issues. Please advise.

Thank you.
__________________
the party just started...
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:04 AM.


© 2014 F+W All rights reserved.