WetCanvas
Home Member Services Content Areas Tools Info Center WC Partners Shop Help
Channels:
Search for:
in:

Welcome to the WetCanvas forums. You are currently viewing our boards as a guest which gives you limited access to view most discussions, articles and access our other FREE features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload your own photos and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please visit our help center.

Go Back   WetCanvas > The Town Center > WC Site Technical Discussions
User Name
Password
Register Mark Forums Read

Salute to our Partners
WC! Sponsors

Our Sponsors
Reply
 
Thread Tools Display Modes
  #1   Report Bad Post  
Old 09-09-2018, 10:23 AM
Adrian.B Adrian.B is offline
Senior Member
France
 
Join Date: Aug 2018
Posts: 124
 
Hails from France
Forum bugs

This is a crosspost with the welcome forum.

Bug report:
_I can't click on any part of the gray window surrounding the text area (no smiley, no Bold tag, etc ...).
_To use basic features like including images, I have either to write the BBCode or the HTLM code. Which code I should use appears to be random (ie sometimes only BBCode will work, sometime only HTLM code will work). Most of the time when I'm doing a "quick answer" it's BBCode that is required, and when doing "advanced answer" it's HTLM code that is required, although it is not always the case.
_ When clicking the "Preview button", some of the special characters go completely crazy, like" which becomes " . It means that each time that I'm hitting preview, I must do a copy/past of all my text first to not lose it.

Software description:
I'm currently using Firefox Quantum 61.0.2, although I tested it with Internet Explorer 11.228 and it doesn't work better. Both these browsers are up-to-date with the latest HTLM in use. I'm using Windows 10 for what it's relevant, although it shouldn't change anything.

Also, I'd like to repport that it's extremely confusing that WetCanvas is using both a http and a https protocol. Please consider removing the http one as it is obsolete and may induce people to not use a safe protocol.

Thanks.
__________________
My paintings: https://www.facebook.com/AdBpaintings
- C&C always welcome -
Reply With Quote
  #2   Report Bad Post  
Old 09-09-2018, 12:59 PM
~JMW~'s Avatar
~JMW~ ~JMW~ is offline
A WetCanvas! Patron Saint
Oregon
 
Join Date: Oct 2004
Posts: 3,093
 
Hails from United States
Re: Forum bugs

Haven't seen this problem mentioned ..
Usually it is the nasty pop up that some will get..

Desktop, phone, tablet?
That may or may not matter I don't know..
What about Chrome or other browsers?
Do you have any browser add ons that might be affecting the page display/function for your system.. My only ad on is Ublock origin..

I would try a different with browser- fresh clean install and see what happens..
I used these before I switched to Linux..
https://www.comodo.com/home/browsers...t-products.php
Or , maybe some deep scans of your system..Comodo has free tools for that too..

Are you using any antivirus software?

All I see for the url is www.wetcanvas.com.. no http or https...?
__________________
JMW's Paintings
Improve your landscapes- http://www.wetcanvas.com/forums/forumdisplay.php?f=522
Composition Tips http://www.wetcanvas.com/Articles/Jo...120/index.html

Last edited by ~JMW~ : 09-09-2018 at 01:04 PM.
Reply With Quote
  #3   Report Bad Post  
Old 09-09-2018, 06:56 PM
Adrian.B Adrian.B is offline
Senior Member
France
 
Join Date: Aug 2018
Posts: 124
 
Hails from France
Re: Forum bugs

Hello,

Thank you for your time and answer.

The only plug-ins I'm running are Ad-Blocks and Ghostery, I desactivated them and as expected it didn't change a thing. I have an antivirus software although it's just avast. I'm not reallly using internet in any fancy ways though so I think I am virus clean.

It's a good idea to test another distribution, so I just switched to my Linux with Firefox 61.0.1 (100% clean from virus). Also tried from my Iphone7 with Safari (mostly clean I guess, never heard of viruses for Iphone).

Issue 1 is not resolved by any of the alternatives.
Issue 2 I don't know yet. Just pressing "enter" to switch line is OK for now, both on my Linux and Iphone, but I'd need to make an extensive use of WC on these to be sure it's not just random luck.
Issue 3 is still present both on my Linux and Iphone7 (the characters are not the same on my Iphone).

I'm not encountering any similar issue with any other website (only really using Facebook and Youtube, though).

Regarding the protocol, your browser might not show you which one is used, and by default I think it's the http one. Try to enter both on your browser and you should see that they both load.
__________________
My paintings: https://www.facebook.com/AdBpaintings
- C&C always welcome -

Last edited by Adrian.B : 09-09-2018 at 06:59 PM.
Reply With Quote
  #4   Report Bad Post  
Old 09-10-2018, 09:32 AM
Yorky's Avatar
Yorky Yorky is online now
Administrator
ORMSKIRK, Lancashire
 
Join Date: May 2000
Posts: 93,737
 
Hails from United Kingdom
Re: Forum bugs

Sounds like a browser update has disabled the feature.

Doug
Reply With Quote
  #5   Report Bad Post  
Old 09-10-2018, 06:46 PM
Adrian.B Adrian.B is offline
Senior Member
France
 
Join Date: Aug 2018
Posts: 124
 
Hails from France
Re: Forum bugs

I think the same, but although this community is probably not the most enthusiastic about new technologies, I find dubious to be the only one with an up-to-date browser ^^

Have you tried to update your browser yourself to see if it makes the site bogus ? If there is such an issue it has to be tackled anyway.
__________________
My paintings: https://www.facebook.com/AdBpaintings
- C&C always welcome -
Reply With Quote
  #6   Report Bad Post  
Old 09-16-2018, 11:29 PM
~JMW~'s Avatar
~JMW~ ~JMW~ is offline
A WetCanvas! Patron Saint
Oregon
 
Join Date: Oct 2004
Posts: 3,093
 
Hails from United States
Re: Forum bugs

My Linux Mint Mate just updated Firefox to 62.0 the other day..
No problems with site or posting..
__________________
JMW's Paintings
Improve your landscapes- http://www.wetcanvas.com/forums/forumdisplay.php?f=522
Composition Tips http://www.wetcanvas.com/Articles/Jo...120/index.html
Reply With Quote
  #8   Report Bad Post  
Old 09-17-2018, 11:09 PM
WoodGuard's Avatar
WoodGuard WoodGuard is offline
New Member
Cape Breton, Canada
 
Join Date: Sep 2001
Posts: 12
 
Hails from Canada
Re: Forum bugs

Not a bug but I think it is a hacked post.

It the thread for RSS feeds there are several porn links.


http://www.wetcanvas.com/forums/show...86884#p4486884

'RSS feed now available for WetCanvas!'

at the bottom of the post is this, several links. Kind of art related.

100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
__________________
Nelson from the far east Islands of Canada.

Facebook: https://www.facebook.com/CranBerryArtWorks
Reply With Quote
  #9   Report Bad Post  
Old 09-17-2018, 11:28 PM
~JMW~'s Avatar
~JMW~ ~JMW~ is offline
A WetCanvas! Patron Saint
Oregon
 
Join Date: Oct 2004
Posts: 3,093
 
Hails from United States
Re: Forum bugs

2 posts with those links by same member in that thread..
I reported them to make sure they got cleaned up..

Anytime you see things like that use the triangle icon up in the corner to report the post..


That ID has a lot of those links in older posts- I finally clicked the links to check them,, they are all old/ broken/errors pages..
But it doesn't look very nice with the link text showing on the site..and on a long time member's posts..
__________________
JMW's Paintings
Improve your landscapes- http://www.wetcanvas.com/forums/forumdisplay.php?f=522
Composition Tips http://www.wetcanvas.com/Articles/Jo...120/index.html

Last edited by ~JMW~ : 09-17-2018 at 11:43 PM.
Reply With Quote
  #10   Report Bad Post  
Old 09-18-2018, 02:28 AM
Yorky's Avatar
Yorky Yorky is online now
Administrator
ORMSKIRK, Lancashire
 
Join Date: May 2000
Posts: 93,737
 
Hails from United Kingdom
Re: Forum bugs

We deal with such posts when reported. Those historic hacks have been deleted back to 2011.

Doug
Reply With Quote
  #11   Report Bad Post  
Old 09-20-2018, 08:35 PM
Adrian.B Adrian.B is offline
Senior Member
France
 
Join Date: Aug 2018
Posts: 124
 
Hails from France
Re: Forum bugs

Quote:
Originally Posted by ~JMW~
My Linux Mint Mate just updated Firefox to 62.0 the other day..
No problems with site or posting..
Okay. Not being an expert in the Web technologies, I have no clues then. Anyway even if the admins don't want to tackle my issues, they should still take into account my remark about the http/https protocol. Using the old HTTP protocol involves that a third party may spy the ID+passwords of users. It also involves that a third party may modify the code of the page sent to the client (did anybody mention nasty pop-ups ?).
__________________
My paintings: https://www.facebook.com/AdBpaintings
- C&C always welcome -
Reply With Quote
  #12   Report Bad Post  
Old 09-20-2018, 11:38 PM
~JMW~'s Avatar
~JMW~ ~JMW~ is offline
A WetCanvas! Patron Saint
Oregon
 
Join Date: Oct 2004
Posts: 3,093
 
Hails from United States
Re: Forum bugs

[The Administrators are Doug (Yorky), and Marty (MartyC), and WetCanvas' Community Manager,
Sarah (sallspaw). Sarah is the "lead administrator" representing the owner, F+W Media.
Jamie Markle is also an administrator, artist and the Publisher/Editorial Director for all of F+W's Fine Art publications. While Dan Sargent (dsargent) is the Online Product Manager for all of F+W's art-related websites, including WetCanvas. The Administrators keep the site functioning on a day-to-day basis.
Sarah is responsible for pushing forward the site with new improvements and updates and technology implementation as well as more educational tools and offerings, Doug and Marty act as advisors to all moderators as well as create new forums, and develop the structure for integrating new topics and volunteers.]
__________________
JMW's Paintings
Improve your landscapes- http://www.wetcanvas.com/forums/forumdisplay.php?f=522
Composition Tips http://www.wetcanvas.com/Articles/Jo...120/index.html
Reply With Quote
  #13   Report Bad Post  
Old 09-20-2018, 11:46 PM
WoodGuard's Avatar
WoodGuard WoodGuard is offline
New Member
Cape Breton, Canada
 
Join Date: Sep 2001
Posts: 12
 
Hails from Canada
Re: Forum bugs

I think the forum runs very well. Yes, there are a few dead links. but with the massive amount of information on the site, that will happen.

I think the admins are doing a great job.
__________________
Nelson from the far east Islands of Canada.

Facebook: https://www.facebook.com/CranBerryArtWorks
Reply With Quote
  #14   Report Bad Post  
Old 09-21-2018, 02:05 AM
Yorky's Avatar
Yorky Yorky is online now
Administrator
ORMSKIRK, Lancashire
 
Join Date: May 2000
Posts: 93,737
 
Hails from United Kingdom
Re: Forum bugs

Marty and Sarah Allspaw have not been involved for years. This is the problem,much of the information on the sidebars and other parts of the forum framework are frozen in time since a botched backup and migration lost us access to those areas.

The current list of Admins, Moderators and Guides is in a separate thread at the top is the forum. Current Administrators are for F+W Courtney Jordan and the voluntary ones are Jon, vmrs and Yorky.

Responsibility for the site management rests with F+W who have been asked to implement Https.

Doug
Reply With Quote
  #15   Report Bad Post  
Old 09-21-2018, 06:40 AM
Adrian.B Adrian.B is offline
Senior Member
France
 
Join Date: Aug 2018
Posts: 124
 
Hails from France
Re: Forum bugs

Thanks ~JMW~ for the additional information. My point was not to criticize the admins (WC is huuuuge and I'm sure it's a ton of work to keep it running, so good job guys ). I now understand that admins don't manage the forum on a technical level. At the same time, I felt obligated to notify what I would consider a huge flaw in security. I think it's admins' job to make the information arrive to whoever is in charge.

Quote:
Responsibility for the site management rests with F+W who have been asked to implement Https.

HTTPS appears to be already implemented. The problem is that HTTP is still online. If you type "WetCanvas" on google, it's the HTTP page that comes first. Users that are unaware of it and don't specifically look for the HTTPS version are not navigating safely on the site.

Cheers,
Adrian.B
__________________
My paintings: https://www.facebook.com/AdBpaintings
- C&C always welcome -
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:49 AM.


© 2014 F+W All rights reserved.